お知らせ‎ > ‎

schesim version 0.8.0 を公開しました。

2013/11/29 5:39 に Yutaka Matsubara が投稿   [ 2013/11/29 8:45 に更新しました ]
Ruby 1.9系、2.0系で動作する schesim version 0.8.0 のソースコードパッケージを公開しました。
ダウンロードページから取得できます。

version 0.7.3からの主な変更点は、以下の通りです。
  • シミュレータ本体(schesim.rb)
    • 機能追加
      • アプリケーションフック機能を追加.
    • その他
      • タスク関数の実装をThreadからFiberに変更.それに伴い,Ruby 1.9.x 以降の環境でのみ動作する.Ruby 1.8.x 以前はサポート外とする.
      • Rakefileの軽微な修正.
      • バージョン番号を0.7.3に更新.
変更点の詳細は、ソースコードパッケージ内のCHANGESファイルをご覧ください。

このリリースでは、シミュレータの機能に大きな変更はありませんが、動作環境が ruby 1.8系から 1.9.3 以降に変更になりました。
これにより、シミュレーション速度が3〜5倍程度高速化されました。rubyの1.9.3からサポートされたFiberを使用していますので、1.9.2以前のrubyでは動作しません。ご注意ください。

本シミュレータに関するご質問やご要望等を、常時受け付けています。
お気軽にお問い合わせください。